js2-mode が emacs 23 で動かなくてこまった件

チラシの裏的に。何か知っている人がいたらご一報

公式 (http://code.google.com/p/js2-mode/) は emacs 22 で動くと書いてあるのだけど、prog-modeがそもそも emacs 24 からという話らしくてその辺りでコケる。確かに手で emacs 24 をコンパイルして動かしてみるとそこは動く。代わりにパッケージでインストールした他のものがコケてなんだこれ。

そもそもJavaScriptをちこっといじるのに少しヨサゲなものを、と思って軽い気持ちで準備したら何か大変面倒なことになった。emacs 24 を手元で入れても今回作業するのは別のサーバであって、手元とこっちで環境微妙に違うんだよね。こういう巨大なのを手でやると絶対設定ファイル周りで余計な作業が入ったりするからパッケージ以外であんまりやりたくないってところもある。パッケージ管理が得意であればまだともかくとして

で、調べてたら偶然ブランチした方 (https://github.com/mooz/js2-mode) が prog-mode をどういう理由でか呼んでおらず、そっちは動いた。背景事情は調べてない。

このブログの人気の投稿

WiiUのコントローラが通信不良に陥った話

LibreOfficeで表紙、目次、本体でフッターのページ番号のスタイルを変える

技術書典2 あ-03 『もわねっとのPythonの本』